ford cvt cft30

User avatar
dhritsko
Posts: 1111
Joined: Mon Oct 28, 2013 3:43 pm
First Name: David
Last Name: Hritsko
Other:
Location: Walton Hills , OH

Re: ford cvt cft30

Post by dhritsko » Tue Mar 06, 2018 5:10 pm

please keep me informed
Dave Hritsko
Transtar Industries
Technical Service Manager

sirrealism
Posts: 172
Joined: Thu Apr 24, 2014 11:13 am
First Name: Brant
Last Name: LaVigne
Other:

Re: ford cvt cft30

Post by sirrealism » Tue Mar 06, 2018 5:14 pm

I did use a CVT synthetic fluid. Just not fords. I have done several of these and used the same fluid each time. But maybe this is the issue. Need to convince the shop owner to buy the right fluid.

sirrealism
Posts: 172
Joined: Thu Apr 24, 2014 11:13 am
First Name: Brant
Last Name: LaVigne
Other:

Re: ford cvt cft30

Post by sirrealism » Tue Mar 06, 2018 5:50 pm

Going to pull the unit out again and look for some kind of leak.

User avatar
dhritsko
Posts: 1111
Joined: Mon Oct 28, 2013 3:43 pm
First Name: David
Last Name: Hritsko
Other:
Location: Walton Hills , OH

Re: ford cvt cft30

Post by dhritsko » Wed Mar 07, 2018 10:50 am

show the customer the tech bulletin . Had a shop use CVT fluid in a Ford and had the same type of issue , changed fluid and it got better but he still had slight issues . He believed the frictions and converter clutch got ruined by the wrong fluid so he changed them out and used Ford fluid and all was good . Lubegard states theirs will work in Fords also but me myself would use OE fluid . I create enough issues my self so when I hear or experience issues I try to not shoot myself anymore . I use Honda fluid in Honda and Toyota fluid in Toyotas . I'm to the point where anything 6 speeds up get OE fluid , just do not need the issues for the few I do .
Dave Hritsko
Transtar Industries
Technical Service Manager

sirrealism
Posts: 172
Joined: Thu Apr 24, 2014 11:13 am
First Name: Brant
Last Name: LaVigne
Other:

Re: ford cvt cft30

Post by sirrealism » Wed Mar 14, 2018 1:04 pm

So I went back through the unit. Found some wear on the secondary end cover so I felt it might be loosing some pressure there. Put the unit in and factory fluid and it made it about 2 miles before it set all the codes again. I got a junk yard unit that has bearing problems that I am going through. Maybe there is a leak inside one of the pulleys. I will post what happened.

User avatar
dhritsko
Posts: 1111
Joined: Mon Oct 28, 2013 3:43 pm
First Name: David
Last Name: Hritsko
Other:
Location: Walton Hills , OH

Re: ford cvt cft30

Post by dhritsko » Wed Mar 14, 2018 1:07 pm

holy smokes , you're making the best move I believe
Dave Hritsko
Transtar Industries
Technical Service Manager

sirrealism
Posts: 172
Joined: Thu Apr 24, 2014 11:13 am
First Name: Brant
Last Name: LaVigne
Other:

Re: ford cvt cft30

Post by sirrealism » Thu Mar 29, 2018 10:02 am

building another unit was the fix. Car has been on the rd for a couple weeks now. Didn't want to post until I was sure it was fixed

User avatar
dhritsko
Posts: 1111
Joined: Mon Oct 28, 2013 3:43 pm
First Name: David
Last Name: Hritsko
Other:
Location: Walton Hills , OH

Re: ford cvt cft30

Post by dhritsko » Thu Mar 29, 2018 11:41 am

Good Job Sir
Dave Hritsko
Transtar Industries
Technical Service Manager

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests