c4 no 3rd

Post Reply
craigrushton
Posts: 198
Joined: Mon Jan 27, 2014 2:43 pm
First Name: craig
Last Name: rushton
Other:

c4 no 3rd

Post by craigrushton » Thu Nov 02, 2017 7:17 pm

ok just rebuilt this one its driving me nuts came in with a failed trans cooler not moving at all rebuilt trans got it installed shifts in rev fine 1-2 fine but will not go in to third at all pulled valve body apart my shift valves move air checked it while valve body was off checks great, changed modulators nothing changes it i moved to shifter up and down to see if I was starting in 2 and getting a shift 2-3 as some c4 were like that no change. simple little unit driving me nuts trying to find the issue any help would be great

trans136005c
Posts: 45
Joined: Thu Oct 31, 2013 3:15 pm
Other:

Re: c4 no 3rd

Post by trans136005c » Fri Nov 03, 2017 7:13 am

what year?

trans136005c
Posts: 45
Joined: Thu Oct 31, 2013 3:15 pm
Other:

Re: c4 no 3rd

Post by trans136005c » Fri Nov 03, 2017 7:46 am

64 governor will bolt on 180 off ,no gov pressure

craigrushton
Posts: 198
Joined: Mon Jan 27, 2014 2:43 pm
First Name: craig
Last Name: rushton
Other:

Re: c4 no 3rd

Post by craigrushton » Fri Nov 03, 2017 11:49 am

the trans is in a 67 but it is a c5 valve body casting i moved the shifter from where green dot would be to the lower position and nothing i am going to check the govoner now

craigrushton
Posts: 198
Joined: Mon Jan 27, 2014 2:43 pm
First Name: craig
Last Name: rushton
Other:

Re: c4 no 3rd

Post by craigrushton » Fri Nov 03, 2017 12:35 pm

pulled gov off it is bolted up correctly and the valves free i know i have good sealing rings there it air checks i can hear them flutter when i apply air through the out and a thud when i apply it through the in has to be valve body even tho i took it apart 4 times now frustrating to no end when these simple little units fight like this

trans136005c
Posts: 45
Joined: Thu Oct 31, 2013 3:15 pm
Other:

Re: c4 no 3rd

Post by trans136005c » Fri Nov 03, 2017 2:03 pm

servo release air check ok?

carod
Posts: 155
Joined: Wed Aug 10, 2016 6:53 pm
First Name: Rod
Last Name: Roy
Other:
Location: Calgary, Alberta

Re: c4 no 3rd

Post by carod » Fri Nov 03, 2017 2:14 pm

Years ago we had a modulator valve put into the case backwards. This causes
some weird problems. When you assemble the valve body tighten the haves together
first then tighten the end plates second. Check the modulator pin length and try another
valve body. Good Luck

craigrushton
Posts: 198
Joined: Mon Jan 27, 2014 2:43 pm
First Name: craig
Last Name: rushton
Other:

Re: c4 no 3rd

Post by craigrushton » Tue Nov 07, 2017 3:11 pm

valve body fixed it unfortunately i had to get another c5 for it so his shifter does not match the valve body he has to drive it around in d2 for 123 shifts but he was happy and i was happy to see it go down the road

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests