2014 PROMASTER 3500 3.8L 62te transmission

Post Reply
joseluis
Posts: 23
Joined: Sun Apr 12, 2015 2:46 pm
First Name: JOSE
Last Name: ULLOA
Other:

2014 PROMASTER 3500 3.8L 62te transmission

Post by joseluis » Sun Jan 07, 2018 5:57 pm

After overhaul it drips a little through the front. mainly after running. but not while it is running.
I have replaced the bushing and seal two times with gasquet and pump o ring and still drips after
siting for five minutes after running it has a very slow drip.
I sat for more than 10 minutes watching it while running and no drip till shot off.
I chequed the flywheel, and it has a very mild run-out at the ring gear.
Also any good way to check the level. specs call for 9.5 quarts.
and it wont show on a regular tool.
Thank you all in advance!!

carod
Posts: 155
Joined: Wed Aug 10, 2016 6:53 pm
First Name: Rod
Last Name: Roy
Other:
Location: Calgary, Alberta

Re: 2014 PROMASTER 3500 3.8L 62te transmission

Post by carod » Mon Jan 08, 2018 12:26 am

Did you replace the convertor?

joseluis
Posts: 23
Joined: Sun Apr 12, 2015 2:46 pm
First Name: JOSE
Last Name: ULLOA
Other:

Re: 2014 PROMASTER 3500 3.8L 62te transmission

Post by joseluis » Tue Jan 09, 2018 10:58 pm

Two times.dowel pins seem fine too

joseluis
Posts: 23
Joined: Sun Apr 12, 2015 2:46 pm
First Name: JOSE
Last Name: ULLOA
Other:

Leak fixed 2014 PROMASTER 3500 3.8L 62te transmission

Post by joseluis » Tue Jan 23, 2018 7:02 pm

For the final time i pulled the transmission and check the bushing and o ring.all good .and pulled the pump seal out.
the seal was all moist around with ATF.so I replaced the bushing(since it is out )with a sonnax bushing. and remove the glue out of a new seal,and dabbed it around with green lock tite.Installed the transmission back and test drove it for miles.no leaks.customer is out in arizona driving it. to test it right.
No leaks to date. one week and it looks good!

carod
Posts: 155
Joined: Wed Aug 10, 2016 6:53 pm
First Name: Rod
Last Name: Roy
Other:
Location: Calgary, Alberta

Re: 2014 PROMASTER 3500 3.8L 62te transmission

Post by carod » Tue Jan 30, 2018 11:44 pm

Good Job

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests