5-45 RFE 2010 dodge ram 1500 Transmission problem

Post Reply
a2ztrans
Posts: 2
Joined: Tue May 09, 2017 1:37 pm
First Name: Brian
Last Name: Fleck
Other:

5-45 RFE 2010 dodge ram 1500 Transmission problem

Post by a2ztrans » Tue May 09, 2017 5:25 pm

The 2010 dodge ram 1500 is having a problem with being stuck in 4th gear. when you go to shift it into drive it just goes right into 4th gear. reverse still works.
scanner codes are P0770 4C solenoid circuit and P0882 TCM power input low has anyone had a similar problem and found a fix for it?

User avatar
dhritsko
Posts: 1110
Joined: Mon Oct 28, 2013 3:43 pm
First Name: David
Last Name: Hritsko
Other:
Location: Walton Hills , OH

Re: 5-45 RFE 2010 dodge ram 1500 Transmission problem

Post by dhritsko » Wed May 10, 2017 8:10 am

sounds like limp mode , if you clear codes does it shift ?
Dave Hritsko
Transtar Industries
Technical Service Manager

a2ztrans
Posts: 2
Joined: Tue May 09, 2017 1:37 pm
First Name: Brian
Last Name: Fleck
Other:

Re: 5-45 RFE 2010 dodge ram 1500 Transmission problem

Post by a2ztrans » Wed May 10, 2017 12:17 pm

It only works for 30 seconds then back to fourth

User avatar
dhritsko
Posts: 1110
Joined: Mon Oct 28, 2013 3:43 pm
First Name: David
Last Name: Hritsko
Other:
Location: Walton Hills , OH

Re: 5-45 RFE 2010 dodge ram 1500 Transmission problem

Post by dhritsko » Wed May 10, 2017 2:29 pm

sounds like a bad TCM
Dave Hritsko
Transtar Industries
Technical Service Manager

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest