48RE no line pressure

Post Reply
Tims Trans
Posts: 20
Joined: Thu Jan 03, 2019 11:57 am
First Name: Tim
Last Name: Schmidt
Other:

48RE no line pressure

Post by Tims Trans » Sat Mar 14, 2020 11:51 am

2003 Dodge Ram Cummins I rebuilt this unit and it will not go in any gear. when it came in it would not move in any gear. It has a master kit, billit single disc converter, new seperator plate drilled to match old one and new forward cooler. removed one way check ball in pressure line. On start up it would not go in gear just like before and after tapping on the gas a bit to try to get it to move it blew the pressure line off the forward cooler and I had 4 quarts of ATF on my floor. I check the line pressure and it was 0 PSI I Have no codes the car dealer that Im doing this for Had to buy a new key for it it starts but the security alarm goes on. thanks for any responses
Tim

Tims Trans
Posts: 20
Joined: Thu Jan 03, 2019 11:57 am
First Name: Tim
Last Name: Schmidt
Other:

Re: 48RE no line pressure (possibly fixed)

Post by Tims Trans » Mon Mar 16, 2020 10:39 am

I believe I found the issue. we will find out when I get it back together. the switch valve was missing its spring keeping the valve outboard witch from my research will cause 0 line pressure. I let you know the results witch may not be quick because I have to babysit all my grand kids because of this coronavis Pandemic.
Thanks
Tim

Tims Trans
Posts: 20
Joined: Thu Jan 03, 2019 11:57 am
First Name: Tim
Last Name: Schmidt
Other:

Re: 48RE no line pressure (fixed)

Post by Tims Trans » Mon Mar 16, 2020 11:19 pm

Yep that was it. Thanks for veiwing
Tim

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest